Page 1 of 1

Need Old Software

Posted: June 30th, 2008, 10:04 am
by ffeer
I've been culling old file in the process of transitioning to OSX10.4 and discover that in the course of years some old applications have disappeared leaving orphaned files I'd like to access.

Specifically: MacDraw, Procite 4.0.2, DiscDoubler and Canvas 5.

I'd appreciate leads to copies currently useable under 9.2.2 so tat I can access the files for copying to current media.

please reply to [email protected]

thanks

Re: Need Old Software

Posted: July 5th, 2008, 8:32 am
by madmann
i can tell you disk doubler will only work up to os 7.6.1

after that no joy

michael

Re: Need Old Software

Posted: February 26th, 2009, 5:23 pm
by Big Ugly Mich
Try this site, which admittedly features freeware and shareware, but hey. . . http://www.tucows.com