Flash not working in Safari

FrMark
8 MB
Posts: 9
Joined: December 11th, 2013, 3:39 pm

Flash not working in Safari

Postby FrMark » January 14th, 2017, 10:39 am

Since updating Safari to the latest version for El Capitan (Safari version 10.0.2) I have not been able to see Flash video in web pages. I know they are there (one because it is in my own blog and I put it there!) because I can see them in Opera or on my Windows machine in Firefox.

Anyone know how I can recover Flash in Safari, please? I have trawled through all the options and can see nothing relevant.

Thanks.

Mark
User avatar
Turboladdade
1024 MB
Posts: 1363
Joined: October 31st, 2007, 10:44 pm

Re: Flash not working in Safari

Postby Turboladdade » January 14th, 2017, 12:32 pm

I'm on the latest version of Safari and see Flash fine. You can make sure you have the latest version of Flash by visiting https://get.adobe.com/flashplayer/ — be wary of add-ons they include with the installer.

You also want to make sure you have Flash enabled in Safari preferences (see screenshot).
Attachments
Screen Shot 2017-01-14 at 11.31.50 AM.png
I am now telling the computer exactly what it can do.
FrMark
8 MB
Posts: 9
Joined: December 11th, 2013, 3:39 pm

Re: Flash not working in Safari

Postby FrMark » January 15th, 2017, 8:58 am

Thanks. I'll check that I have the latest version, but I'm on automatic updates. Flash is enabled for the websites in question. Mystery!

M
FrMark
8 MB
Posts: 9
Joined: December 11th, 2013, 3:39 pm

Re: Flash not working in Safari

Postby FrMark » January 15th, 2017, 9:11 am

Hmm. Installed latest version (24.0.0.194) for my OS. Checked all settings and, for now, allowed Flash on everything, just in case I had something wrong. No change.

Remembered Java had not been allowed for any website so allowed that for the sites in question and that has not changed anything either - but I didn't expect it would. Getting nowhere here.

On this web page: https://mwtrips.blogspot.co.uk/2016/12/ ... gland.html there should be a video clip between the 2nd and 3rd photographs, but all I get is a blank space.

More evidence is that my wife's (younger) MacBook showed the video (after asking for permission to use the Flash plug-in) until I updated her Safari yesterday .... which is what drove me to ask on here.

M
User avatar
Turboladdade
1024 MB
Posts: 1363
Joined: October 31st, 2007, 10:44 pm

Re: Flash not working in Safari

Postby Turboladdade » January 16th, 2017, 8:39 am

What happens when you try another browser such as Chrome?
I am now telling the computer exactly what it can do.
FrMark
8 MB
Posts: 9
Joined: December 11th, 2013, 3:39 pm

Re: Flash not working in Safari

Postby FrMark » January 17th, 2017, 2:37 pm

It is fine in Opera.

Most odd.

I may have to bite the bullet and upgrade to Sierra to see if that fixes it. I'm always nervous about changing the OS, though, ever since I lost the ability to print with one upgrade and it took a lot of effort to get it back! I also need enough time ...
User avatar
rosso
16 MB
Posts: 16
Joined: February 25th, 2017, 9:42 am

Re: Flash not working in Safari

Postby rosso » February 26th, 2017, 8:31 am

Probably not much help but on your link, like you I get the photos but the You Tube video does say, 'This video is private' Although I do see a black rectangle typical of a You Tube video.

My Flash version: You have version 24,0,0,221 installed- Safari Version 10.0.3 (11602.4.8.0.1) - El Capitan

(Just posting this while I await approval to post - if that makes sense.)

:)
FrMark
8 MB
Posts: 9
Joined: December 11th, 2013, 3:39 pm

Re: Flash not working in Safari

Postby FrMark » February 28th, 2017, 5:49 pm

That's because I gave up and posted a YouTube video in place of the embedded one that had been there. I obviously must have made it "private" - whatever that means. I shall have to look at YouTube and see where I've gone wrong on public access! Still no wiser on flash.
User avatar
rosso
16 MB
Posts: 16
Joined: February 25th, 2017, 9:42 am

Re: Flash not working in Safari

Postby rosso » March 1st, 2017, 12:15 pm

Thanks for reporting back - re; Flash, me neither !

Any info here: https://helpx.adobe.com/flash-player/kb ... afari.html
Tiger+Classic / Snow Leopard / El Capitan - Previously; Mac System 7.5.5 - BeOS something, I forget now on a Beige 9600 with MacOS 8 although it took a bit of tweeking...

  • Similar Topics
    Replies
    Views
    Last post

Return to “Mac Discussion”



Who is online

Users browsing this forum: No registered users and 3 guests